<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
    <meta charset="UTF-8">
    <meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=5">
        <meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<!-- start: Estudio Patagon Meta Tags -->
<meta property="description" content="Ncat command in Linux or NC command is used in the maintenance or diagnosis-related tasks for a network. Even though the ‘nc command’ or ‘ncat..."/>
<meta property="og:locale" content="en_US" />
<meta property="og:title" content="Informative guide to NC (Ncat) command in Linux - The Linux GURUS"/>
<meta property="og:description" content="Ncat command in Linux or NC command is used in the maintenance or diagnosis-related tasks for a network. Even though the ‘nc command’ or ‘ncat..."/>
<meta property="og:image" content="https://i2.wp.com/thelinuxgurus.com/wp-content/uploads/2021/03/unnamed-file.png?fit=850%2C500&amp;ssl=1"/>
<meta property="og:type" content="article"/>
<meta property="og:url" content="https://thelinuxgurus.com/informative-guide-to-nc-ncat-command-in-linux/"/>
<meta property="og:site_name" content="The Linux GURUS"/>
<meta property="article:published_time" content="2021-03-24T21:28:49+05:30" />
<meta property="article:modified_time" content="2021-03-24T21:28:49+05:30" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Ncat command in Linux or NC command is used in the maintenance or diagnosis-related tasks for a network. Even though the ‘nc command’ or ‘ncat..." />
<meta name="twitter:title" content="Informative guide to NC (Ncat) command in Linux - The Linux GURUS" />
<meta name="twitter:image" content="https://i2.wp.com/thelinuxgurus.com/wp-content/uploads/2021/03/unnamed-file.png?fit=850%2C500&#038;ssl=1" />
<!-- end: Estudio Patagon Meta Tags -->

	<!-- This site is optimized with the Yoast SEO plugin v16.0.2 - https://yoast.com/wordpress/plugins/seo/ -->
	<link media="all" href="https://thelinuxgurus.com/wp-content/cache/autoptimize/css/autoptimize_7067a3a1511e973ee6d7229df53501f9.css" rel="stylesheet" /><title>Informative guide to NC (Ncat) command in Linux - The Linux GURUS</title>
	<meta name="description" content="Ncat or nc command in Linux is used in the maintenance or diagnosis-related tasks for a network. Ncat command can be used as a utility to" />
	<link rel="canonical" href="https://thelinuxgurus.com/informative-guide-to-nc-ncat-command-in-linux/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Informative guide to NC (Ncat) command in Linux - The Linux GURUS" />
	<meta property="og:description" content="Ncat or nc command in Linux is used in the maintenance or diagnosis-related tasks for a network. Ncat command can be used as a utility to" />
	<meta property="og:url" content="https://thelinuxgurus.com/informative-guide-to-nc-ncat-command-in-linux/" />
	<meta property="og:site_name" content="The Linux GURUS" />
	<meta property="article:published_time" content="2021-03-24T15:58:49+00:00" />
	<meta property="og:image" content="https://i2.wp.com/thelinuxgurus.com/wp-content/uploads/2021/03/unnamed-file.png?fit=850%2C500&#038;ssl=1" />
	<meta property="og:image:width" content="850" />
	<meta property="og:image:height" content="500" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:label1" content="Written by">
	<meta name="twitter:data1" content="Prince DAN">
	<meta name="twitter:label2" content="Est. reading time">
	<meta name="twitter:data2" content="6 minutes">
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://thelinuxgurus.com/#website","url":"https://thelinuxgurus.com/","name":"The Linux GURUS","description":"Learn Linux &amp; DevOPS from THE LINUX GURUS","publisher":{"@id":"https://thelinuxgurus.com/#/schema/person/7a099bd560e6079ac717d5af4c4df016"},"potentialAction":[{"@type":"SearchAction","target":"https://thelinuxgurus.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://thelinuxgurus.com/informative-guide-to-nc-ncat-command-in-linux/#primaryimage","inLanguage":"en-US","url":"https://i2.wp.com/thelinuxgurus.com/wp-content/uploads/2021/03/unnamed-file.png?fit=850%2C500&ssl=1","width":850,"height":500},{"@type":"WebPage","@id":"https://thelinuxgurus.com/informative-guide-to-nc-ncat-command-in-linux/#webpage","url":"https://thelinuxgurus.com/informative-guide-to-nc-ncat-command-in-linux/","name":"Informative guide to NC (Ncat) command in Linux - The Linux GURUS","isPartOf":{"@id":"https://thelinuxgurus.com/#website"},"primaryImageOfPage":{"@id":"https://thelinuxgurus.com/informative-guide-to-nc-ncat-command-in-linux/#primaryimage"},"datePublished":"2021-03-24T15:58:49+00:00","dateModified":"2021-03-24T15:58:49+00:00","description":"Ncat or nc command in Linux is used in the maintenance or diagnosis-related tasks for a network. Ncat command can be used as a utility to","breadcrumb":{"@id":"https://thelinuxgurus.com/informative-guide-to-nc-ncat-command-in-linux/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://thelinuxgurus.com/informative-guide-to-nc-ncat-command-in-linux/"]}]},{"@type":"BreadcrumbList","@id":"https://thelinuxgurus.com/informative-guide-to-nc-ncat-command-in-linux/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://thelinuxgurus.com/","url":"https://thelinuxgurus.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://thelinuxgurus.com/informative-guide-to-nc-ncat-command-in-linux/","url":"https://thelinuxgurus.com/informative-guide-to-nc-ncat-command-in-linux/","name":"Informative guide to NC (Ncat) command in Linux"}}]},{"@type":"Article","@id":"https://thelinuxgurus.com/informative-guide-to-nc-ncat-command-in-linux/#article","isPartOf":{"@id":"https://thelinuxgurus.com/informative-guide-to-nc-ncat-command-in-linux/#webpage"},"author":{"@id":"https://thelinuxgurus.com/#/schema/person/7a099bd560e6079ac717d5af4c4df016"},"headline":"Informative guide to NC (Ncat) command in Linux","datePublished":"2021-03-24T15:58:49+00:00","dateModified":"2021-03-24T15:58:49+00:00","mainEntityOfPage":{"@id":"https://thelinuxgurus.com/informative-guide-to-nc-ncat-command-in-linux/#webpage"},"commentCount":0,"publisher":{"@id":"https://thelinuxgurus.com/#/schema/person/7a099bd560e6079ac717d5af4c4df016"},"image":{"@id":"https://thelinuxgurus.com/informative-guide-to-nc-ncat-command-in-linux/#primaryimage"},"keywords":"commands,linux commands,nc,ncat","articleSection":"DevOps,HowTo's","inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://thelinuxgurus.com/informative-guide-to-nc-ncat-command-in-linux/#respond"]}]},{"@type":["Person","Organization"],"@id":"https://thelinuxgurus.com/#/schema/person/7a099bd560e6079ac717d5af4c4df016","name":"Prince DAN","image":{"@type":"ImageObject","@id":"https://thelinuxgurus.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/37eb7ad923802078085e9d33fcc08567?s=96&d=mm&r=g","caption":"Prince DAN"},"logo":{"@id":"https://thelinuxgurus.com/#personlogo"}}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<link rel='dns-prefetch' href='//widgets.wp.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel="alternate" type="application/rss+xml" title="The Linux GURUS &raquo; Feed" href="https://thelinuxgurus.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Linux GURUS &raquo; Comments Feed" href="https://thelinuxgurus.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Linux GURUS &raquo; Informative guide to NC (Ncat) command in Linux Comments Feed" href="https://thelinuxgurus.com/informative-guide-to-nc-ncat-command-in-linux/feed/" />
		<!-- This site uses the Google Analytics by MonsterInsights plugin v7.17.0 - Using Analytics tracking - https://www.monsterinsights.com/ -->
							<script src="//www.googletagmanager.com/gtag/js?id=UA-154995956-1"  type="text/javascript" data-cfasync="false"></script>
			
				<!-- / Google Analytics by MonsterInsights -->
				
		<!-- thelinuxgurus.com is managing ads with Advanced Ads 1.24.1 – https://wpadvancedads.com/ --><!--noptimize--><script>
						advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}();
						</script>
		<!--/noptimize-->
	



<link rel="preload" as="style" id='epcl-google-fonts-css' onload="this.onload=null;this.rel=`stylesheet`"   href='https://fonts.googleapis.com/css?family=Poppins%3A400%2C400i%2C500%2C600%2C600i%2C700%2C700i%7CMontserrat%3A400%2C500%2C600%2C700&#038;subset=latin%2Clatin-ext&#038;display=swap' type='text/css' media='all' />







<script type='text/javascript' src='https://thelinuxgurus.com/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script>



<link rel="https://api.w.org/" href="https://thelinuxgurus.com/wp-json/" /><link rel="alternate" type="application/json" href="https://thelinuxgurus.com/wp-json/wp/v2/posts/1353" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://thelinuxgurus.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://thelinuxgurus.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://wp.me/pa4Rkr-lP' />
<link rel="alternate" type="application/json+oembed" href="https://thelinuxgurus.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthelinuxgurus.com%2Finformative-guide-to-nc-ncat-command-in-linux%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://thelinuxgurus.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthelinuxgurus.com%2Finformative-guide-to-nc-ncat-command-in-linux%2F&#038;format=xml" />
        
<script data-ad-client="ca-pub-9067500753069914" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<meta name="flattr:id" content="zl30dl">			
      <meta name="onesignal" content="wordpress-plugin"/>
            
			
			
		<script data-ad-client="ca-pub-9186837757068891" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><link rel="icon" href="https://i0.wp.com/thelinuxgurus.com/wp-content/uploads/2020/01/cropped-thelinuxgurus_transparent_name.png?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/thelinuxgurus.com/wp-content/uploads/2020/01/cropped-thelinuxgurus_transparent_name.png?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon" href="https://i0.wp.com/thelinuxgurus.com/wp-content/uploads/2020/01/cropped-thelinuxgurus_transparent_name.png?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/thelinuxgurus.com/wp-content/uploads/2020/01/cropped-thelinuxgurus_transparent_name.png?fit=270%2C270&#038;ssl=1" />
</head>
<body data-rsssl=1 class="post-template-default single single-post postid-1353 single-format-standard wp-embed-responsive aa-prefix-theli-">
    <svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" style="display: none;">

	<symbol id="tag" viewBox="0 0 24 24">
        <g>
            <path fill="none" d="M0 0h24v24H0z"/>
            <path d="M10.9 2.1l9.899 1.415 1.414 9.9-9.192 9.192a1 1 0 0 1-1.414 0l-9.9-9.9a1 1 0 0 1 0-1.414L10.9 2.1zm.707 2.122L3.828 12l8.486 8.485 7.778-7.778-1.06-7.425-7.425-1.06zm2.12 6.364a2 2 0 1 1 2.83-2.829 2 2 0 0 1-2.83 2.829z"/>
        </g>
	</symbol>

    <symbol id="copy" viewBox="0 0 24 24">
        <g>
            <path fill="none" d="M0 0h24v24H0z"/>
            <path d="M7 6V3a1 1 0 0 1 1-1h12a1 1 0 0 1 1 1v14a1 1 0 0 1-1 1h-3v3c0 .552-.45 1-1.007 1H4.007A1.001 1.001 0 0 1 3 21l.003-14c0-.552.45-1 1.007-1H7zM5.003 8L5 20h10V8H5.003zM9 6h8v10h2V4H9v2z"/>
        </g>
    </symbol>

    <symbol id="calendar" viewBox="0 0 24 24">
        <g>
            <path fill="none" d="M0 0h24v24H0z"/>
            <path d="M17 3h4a1 1 0 0 1 1 1v16a1 1 0 0 1-1 1H3a1 1 0 0 1-1-1V4a1 1 0 0 1 1-1h4V1h2v2h6V1h2v2zm-2 2H9v2H7V5H4v4h16V5h-3v2h-2V5zm5 6H4v8h16v-8z"/>
        </g>
    </symbol>

    <symbol id="comments-icon" viewBox="0 0 24 24">
        <g id="a" clip-path="url(#b)"><path d="M24,0H0V24H24Z" fill="none"/><path d="M14,3H10a8,8,0,0,0,0,16v3.5c5-2,12-5,12-11.5a8,8,0,0,0-8-8ZM12,17H10A6,6,0,0,1,10,5h4a6,6,0,0,1,6,6c0,3.61-2.462,5.966-8,8.48Z"/></g>
    </symbol>

    <symbol id="views-icon" viewBox="0 0 24 24">
    <g>
        <path fill="none" d="M0 0h24v24H0z"/>
        <path d="M9 18H4v-8h5v8zm-2-2v-4H6v4h1zm6 0V8h-1v8h1zm2 2h-5V6h5v12zm4-2V4h-1v12h1zm2 2h-5V2h5v16zm1 4H3v-2h19v2z"/>
    </g>
    </symbol>

    <symbol id="envelope" viewBox="1 -95 511.99998 511">
        <path d="m16 32.5v256c0 8.835938 7.164062 16 16 16h448c8.835938 0 16-7.164062 16-16v-256l-240 112zm0 0" fill="#333"/><path d="m480 16.5h-448c-8.835938 0-16 7.164062-16 16l240 112 240-112c0-8.835938-7.164062-16-16-16zm0 0" fill="#333"/><path d="m512 32.117188c0-.207032 0-.386719 0-.59375-.527344-17.289063-14.699219-31.03125-32-31.023438h-448c-17.261719.042969-31.378906 13.769531-31.9023438 31.023438v.59375c0 .207031-.0976562.253906-.0976562.382812v256c0 17.671875 14.328125 32 32 32h448c17.671875 0 32-14.328125 32-32v-256c0-.128906 0-.257812 0-.382812zm-53.839844.382812-202.160156 94.398438-202.160156-94.398438zm-426.160156 256v-230.878906l217.230469 101.375c4.292969 2.003906 9.246093 2.003906 13.539062 0l217.230469-101.375v230.878906zm0 0" fill="#fff"/>
    </symbol>

    <symbol id="tiktok-icon" viewBox="0 0 512 512">
        <path fill="none" d="M0 0h24v24H0z"/>
        <path d="m480.32 128.39c-29.22 0-56.18-9.68-77.83-26.01-24.83-18.72-42.67-46.18-48.97-77.83-1.56-7.82-2.4-15.89-2.48-24.16h-83.47v228.08l-.1 124.93c0 33.4-21.75 61.72-51.9 71.68-8.75 2.89-18.2 4.26-28.04 3.72-12.56-.69-24.33-4.48-34.56-10.6-21.77-13.02-36.53-36.64-36.93-63.66-.63-42.23 33.51-76.66 75.71-76.66 8.33 0 16.33 1.36 23.82 3.83v-62.34-22.41c-7.9-1.17-15.94-1.78-24.07-1.78-46.19 0-89.39 19.2-120.27 53.79-23.34 26.14-37.34 59.49-39.5 94.46-2.83 45.94 13.98 89.61 46.58 121.83 4.79 4.73 9.82 9.12 15.08 13.17 27.95 21.51 62.12 33.17 98.11 33.17 8.13 0 16.17-.6 24.07-1.77 33.62-4.98 64.64-20.37 89.12-44.57 30.08-29.73 46.7-69.2 46.88-111.21l-.43-186.56c14.35 11.07 30.04 20.23 46.88 27.34 26.19 11.05 53.96 16.65 82.54 16.64v-60.61-22.49c.02.02-.22.02-.24.02z"/>
    </symbol>

    <symbol id="patreon-icon" enable-background="new 0 0 24 24" viewBox="0 0 24 24"><path d="m0 .5h4.219v23h-4.219z"/><path d="m15.384.5c-4.767 0-8.644 3.873-8.644 8.633 0 4.75 3.877 8.61 8.644 8.61 4.754 0 8.616-3.865 8.616-8.61 0-4.759-3.863-8.633-8.616-8.633z"/></symbol>

</svg>    <!-- start: #wrapper -->
    <div id="wrapper">
		
<!-- start: #header -->
<header id="header" class="classic">

                      
        <div class="menu-mobile">
            <i class="remixicon remixicon-menu-line"></i>
        </div>
    
	<!-- start: .menu-wrapper -->
	<div class="menu-wrapper">
		<div class="grid-container">
            
							<div class="logo text-logo">
					<a href="https://thelinuxgurus.com/" class="title white no-margin">
												The Linux GURUS					</a>
				</div>
            
            
                            <div class="share-buttons hide-on-tablet hide-on-mobile">
                                            <a href="https://www.facebook.com/thelinuxgurus" target="_blank" rel="nofollow" aria-label="Facebook"><i class="fa fa-facebook"></i></a>
                                                                <a href="https://twitter.com/thelinuxgurus" target="_blank" rel="nofollow" aria-label="Twitter"><i class="fa fa-twitter"></i></a>
                                                                <a href="https://in.linkedin.com/in/linuxtechlab" target="_blank" rel="nofollow" aria-label="Linkedin"><i class="fa fa-linkedin"></i></a>
                                                                <a href="https://www.instagram.com/thelinuxgurus/" target="_blank" rel="nofollow" aria-label="Instagram"><i class="fa fa-instagram"></i></a>
                                                                <a href="https://id.pinterest.com/thelinuxgurus/" target="_blank" rel="nofollow" aria-label="Pinterest"><i class="fa fa-pinterest"></i></a>
                                                                                    <a href="https://thelinuxgurus.tumblr.com/" target="_blank" rel="nofollow" aria-label="Tumblr"><i class="fa fa-tumblr"></i></a>
                                                                                                                                        </div>
                        
			<!-- start: .main-nav -->
			<nav class="main-nav gradient-effect">
				<ul id="menu-main" class="menu"><li id="menu-item-710" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-710"><a href="https://thelinuxgurus.com">Home</a></li>
<li id="menu-item-707" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-707"><a href="https://thelinuxgurus.com/category/devops/">DevOps</a></li>
<li id="menu-item-708" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-708"><a href="https://thelinuxgurus.com/category/howtos/">HowTo&#8217;s</a></li>
<li id="menu-item-709" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-709"><a href="https://thelinuxgurus.com/category/linuxtips/">LinuxTips</a></li>
<li id="menu-item-723" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-723"><a href="https://thelinuxgurus.com/get-in-touch/">Contact Us</a></li>
<li class="search-menu-item hide-on-mobile hide-on-tablet"><a href="#search-lightbox" class="lightbox mfp-inline"><i class="remixicon remixicon-search-line"></i></a></li><li class="subscribe-menu-item hide-on-mobile hide-on-tablet"><a href="http://eepurl.com/hn5UfL" target="_blank" class="subscribe epcl-button red hide-on-tablet hide-on-mobile" rel="nofollow noopener">Subscribe to NewsLetter <i class="fa fa-paper-plane"></i></a></li></ul>			</nav>
            <!-- end: .main-nav -->

                            <a href="#search-lightbox" class="lightbox epcl-search-button mfp-inline hide-on-desktop"><i class="remixicon remixicon-search-line"></i></a>
            
            <div class="clear"></div>
            <div class="border hide-on-tablet hide-on-mobile"></div>
		</div>
		<div class="clear"></div>
	</div>
	<!-- end: .menu-wrapper -->

	<div class="clear"></div>
</header>
<!-- end: #header -->


        <div class="hide-on-mobile hide-on-tablet hide-on-desktop">
        <div id="search-lightbox" class="mfp-hide grid-container grid-small grid-parent">
            <h4 class="title small white textcenter fw-normal hide-on-mobile hide-on-tablet">Press <span>ESC</span> to close</h4>
            <div class="search-wrapper section">                
                <form action="https://thelinuxgurus.com/" method="get" class="search-form">
	<input type="text" name="s" id="s" value="" class="search-field" placeholder="Type to start your search..." aria-label="Type to start your search..." required>
	<button type="submit" class="submit" aria-label="Submit"><i class="remixicon remixicon-search-line"></i></button>
</form>
            </div>
        </div>
    </div>

    	<!-- start: #single -->
	<main id="single" class="main grid-container standard" data-aos="fade">

		<!-- start: .center -->
	    <div class="center content">

			<!-- Fullcover Style -->
            
            <!-- start: .epcl-page-wrapper -->
            <div class="epcl-page-wrapper">

                <!-- start: .content -->
                <div class="left-content grid-70 np-mobile">

                    <article class="main-article post-1353 post type-post status-publish format-standard has-post-thumbnail hentry category-devops category-howtos tag-commands tag-linux-commands tag-nc tag-ncat">

                                            
                                                    <header>

    	<div class="post-format-image post-format-wrapper ">
                                    <div class="featured-image">
                                            <img width="850" height="500" src="https://i2.wp.com/thelinuxgurus.com/wp-content/uploads/2021/03/unnamed-file.png?resize=850%2C500&amp;ssl=1" class="attachment-epcl_single_standard size-epcl_single_standard wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-lazy="false" data-lazy-srcset="https://i2.wp.com/thelinuxgurus.com/wp-content/uploads/2021/03/unnamed-file.png?w=850&amp;ssl=1 850w, https://i2.wp.com/thelinuxgurus.com/wp-content/uploads/2021/03/unnamed-file.png?resize=768%2C452&amp;ssl=1 768w, https://i2.wp.com/thelinuxgurus.com/wp-content/uploads/2021/03/unnamed-file.png?resize=100%2C59&amp;ssl=1 100w, https://i2.wp.com/thelinuxgurus.com/wp-content/uploads/2021/03/unnamed-file.png?resize=700%2C412&amp;ssl=1 700w" data-lazy-sizes="(max-width: 850px) 100vw, 850px" data-lazy-src="https://i2.wp.com/thelinuxgurus.com/wp-content/uploads/2021/03/unnamed-file.png?resize=850%2C500&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />                                        <div class="tags absolute"><a href="https://thelinuxgurus.com/category/devops/" class="tag-link-31">DevOps</a><a href="https://thelinuxgurus.com/category/howtos/" class="tag-link-32">HowTo's</a></div>                </div>
            			</div>

    <!-- start: .meta -->
    <div class="meta">
                    <a href="https://thelinuxgurus.com/author/shsuain/" title="Prince DAN" class="author meta-info hide-on-mobile">                                        
                                    <span class="author-image cover" style="background-image: url('https://secure.gravatar.com/avatar/37eb7ad923802078085e9d33fcc08567?s=96&#038;d=mm&#038;r=g');"></span>
                                <span class="author-name">Prince DAN</span>
            </a>
            

            
                               
                <time class="meta-info" datetime="2021-03-24"><i class="remixicon remixicon-calendar-line"></i> March 24, 2021</time>
            
                            <span class="views-counter meta-info" title="Views">
                    <i class="remixicon remixicon-fire-line"></i> 53                </span>
                        
            <a href="#comments" class="comments tooltip" title="Go to comments">
                <i class="remixicon remixicon-chat-1-line fa-flip-horizontal"></i>
                                    <span class="comment-count">0</span>
                    <!-- <span class="comment-text hide-on-mobile">Comments</span> -->
                            </a>   
        
        <div class="clear"></div>
    
        <h1 class="title no-thumb large bold">Informative guide to NC (Ncat) command in Linux</h1>
    </div>
    <!-- end: .meta -->

	<div class="clear"></div>

</header>                        
                        <section class="post-content">

                            
                                                            <div class="epcl-share-container hide-on-mobile">
                                    <div class="epcl-share">
            
        <a class="facebook " rel="nofollow" href="https://www.facebook.com/sharer/sharer.php?u=https://wp.me/pa4Rkr-lP"
onclick="window.open(this.href, 'facebook-share','width=580,height=296');return false;"><i class="fa fa-facebook"></i></a>
            
    <a class="twitter " rel="nofollow" href="http://twitter.com/share?text=Informative+guide+to+NC+%28Ncat%29+command+in+Linux&url=https://wp.me/pa4Rkr-lP"
onclick="window.open(this.href, 'twitter-share', 'width=550,height=235');return false;"><i class="fa fa-twitter"></i></a>
            
        <a class="linkedin " rel="nofollow" href="https://www.linkedin.com/shareArticle?mini=true&url=https://wp.me/pa4Rkr-lP&title=Informative+guide+to+NC+%28Ncat%29+command+in+Linux&summary=Ncat+command+in+Linux+or+NC+command+is+used+in+the+maintenance+or+diagnosis-related+tasks+for+a+network.+Even+though+the+%E2%80%98nc+command%E2%80%99+or+%E2%80%98ncat..." onclick="window.open(this.href, 'linkedin-share', 'width=490,height=530');return false;"><i class="fa fa-linkedin"></i></a>
            
        <a class="pinterest " rel="nofollow" href="//pinterest.com/pin/create/link/?url=https://wp.me/pa4Rkr-lP&media=https://thelinuxgurus.com/wp-content/uploads/2021/03/unnamed-file.png&description=Informative+guide+to+NC+%28Ncat%29+command+in+Linux" onclick="window.open(this.href, 'pinterest-share', 'width=490,height=530');return false;"><i class="fa fa-pinterest"></i></a>
            
        <a class="telegram " rel="nofollow" href="https://telegram.me/share/url?url=https://wp.me/pa4Rkr-lP&text=Informative+guide+to+NC+%28Ncat%29+command+in+Linux" onclick="window.open(this.href, 'telegram-share', 'width=490,height=530');return false;"><i class="fa fa-telegram"></i></a>
                
        <a class="email " rel="nofollow" href="mailto:?subject=Informative+guide+to+NC+%28Ncat%29+command+in+Linux&body=https://wp.me/pa4Rkr-lP" target="_blank"><i class="fa fa-envelope"></i></a>
            
            <a class="whatsapp " rel="nofollow" href="https://api.whatsapp.com/send?text=https://wp.me/pa4Rkr-lP" data-action="share/whatsapp/share"><i class="fa fa-whatsapp"></i></a>    
        </div>                                </div>
                            
                            <div class="text">
                                <p><span style="font-weight: 400;">Ncat command in Linux or NC command is used in the maintenance or diagnosis-related tasks for a network. Even though the ‘nc command’ or ‘ncat command’ are separate commands but they are similar to how they perform their functions &amp; one can be used or replace by the other.</span></p>
<p><span style="font-weight: 400;">Similar to how CAT common in Linux has the ability to manipulate files, NC command in Linux has the ability to perform operations like read, write, or data redirections over the network. </span></p>
<p><span style="font-weight: 400;">Ncat command can be used as a utility to scan ports, monitoring or can also act as a basic TCP proxy. Organizations can utilize it to review the security of their networks, web servers, telnet servers, mail servers, etc, by checking the ports that are opened or unsecured and then secure them. NC command can also be used to capture information being sent by the system.</span></p>
<p><strong>Recommended Read:  <a href="https://thelinuxgurus.com/how-to-use-nmap-command-to-test-server-network-security/">How to use NMAP command to test Server/Network Security</a></strong></p>
<p><strong>Also Read: <a href="https://thelinuxgurus.com/how-to-use-find-command-in-linux/">How to use FIND command in Linux</a></strong></p>
<p><span style="font-weight: 400;">First, let’s discuss how we can install NC command or Ncat command on Linux systems.</span></p>
<p><strong>Install NC command on CentOS</strong></p>
<p><span style="font-weight: 400;">To install the nc command on Centos, simply run the following command,</span></p>
<p><strong><span style="color: #0000ff;"># yum install nc</span></strong></p>
<p>&nbsp;</p>
<p><strong>Install NC on Ubuntu</strong></p>
<p><span style="font-weight: 400;">Similar to CentOS, the nc command in Ubuntu can be installed with a single command,</span></p>
<p><span style="color: #0000ff;"><strong>$ sudo apt install netcat</strong></span></p>
<p><span style="font-weight: 400;">Now if you also want to know how to install the ncat command in CentOS &amp; Ubuntu, then here are the commands.</span></p>
<p>&nbsp;</p>
<p><strong>Install Ncat command on CentOS or RHEL</strong></p>
<p><span style="font-weight: 400;">Ncat command in CentOS or RHEL is part of the NMAP command. So to install the ncat command on Centos, run the following command,</span></p>
<p><span style="color: #0000ff;"><strong># yum install nmap</strong></span></p>
<p>&nbsp;</p>
<p><strong>Install Ncat on Ubuntu</strong></p>
<p><span style="font-weight: 400;">To install Ncat command in Ubuntu,</span></p>
<p><span style="color: #0000ff;"><strong>$ sudo apt install ncat</strong></span></p>
<p><span style="font-weight: 400;">Now let’s discuss how we can use (NCAT command) NC command in Linux with the help of some examples.</span></p>
<hr />
<h2><b>Examples for NC command/Ncat command</b></h2>
<hr />
<h3><b>Connect to a remote server</b></h3>
<p><span style="font-weight: 400;">The following example shows how we can connect to a remote server with NC command,</span></p>
<p><span style="color: #0000ff;"><strong>$ nc 172.16.16.100 80</strong></span></p>
<p><span style="font-weight: 400;">Or</span></p>
<p><span style="color: #0000ff;"><strong>$ ncat 172.16.16.100 80</strong></span></p>
<p><span style="font-weight: 400;">here, 172.16.16.100 is the IP of the server we want to connect to &amp; 80 is the port number for the remote server. </span></p>
<p><span style="font-weight: 400;">Once the nc command has created the connection, we can then perform some other functions like we can get the  page content with</span></p>
<p><strong>GET/HTTP/1.1</strong></p>
<p><span style="font-weight: 400;">or fetch page name,</span></p>
<p><strong>GET/HTTP/1.1</strong></p>
<p><span style="font-weight: 400;">or we can get the banner for OS fingerprinting with the following,</span></p>
<p><strong>HEAD/HTTP/1.1</strong></p>
<p><span style="font-weight: 400;">This will tell us about the application &amp; version being used to run the webserver.</span></p>
<p>&nbsp;</p>
<h3><b>Listen to inbound connection requests on a port</b></h3>
<p><span style="font-weight: 400;">To use the ncat command in Linux to check for an incoming connection on a port number following example can be referenced,</span></p>
<p><span style="color: #0000ff;"><strong>$ nc -l 80</strong></span></p>
<p><span style="font-weight: 400;">or </span></p>
<p><span style="color: #0000ff;"><strong>$ ncat -l 80</strong></span></p>
<p><span style="font-weight: 400;">This will put NC in listening mode, &amp; it will check port 80 for incoming connection requests. Listening mode will keep on running until terminated manually. </span></p>
<p><span style="font-weight: 400;">If we only need to run listening mode for a given amount of time, we can use option ‘w’ for that,</span></p>
<p><span style="color: #0000ff;"><strong>$ nc -w 20 80</strong></span></p>
<p><span style="font-weight: 400;">or </span></p>
<p><span style="color: #0000ff;"><strong>$ ncat -w 20 80</strong></span></p>
<p><span style="font-weight: 400;">here, 20 means the listening mode is active on port 80 &amp; will check connections for 20 seconds only.</span></p>
<p>&nbsp;</p>
<h3><b>Connecting to UDP ports</b></h3>
<p><span style="font-weight: 400;">Nc command makes TCP ports connections by default. For NC command to make connections to UDP ports, use the option ‘u’,</span></p>
<p><span style="color: #0000ff;"><strong>$ nc -l -u 55</strong></span></p>
<p><span style="font-weight: 400;">or </span></p>
<p><span style="color: #0000ff;"><strong>$ ncat -l -u 55</strong></span></p>
<p><span style="font-weight: 400;">Here, we are connecting to UDP port 55 in listening mode.</span></p>
<p>&nbsp;</p>
<h3><b>Using NC for Port forwarding</b></h3>
<p><span style="font-weight: 400;">Another use for the NC command in Linux is that we can also use it for port forwarding. Using option ‘c’ with the nc command, we can redirect a port to another. An example would be,</span></p>
<p><span style="color: #0000ff;"><strong>$ nc -u -l 80 -c &#8216; nc -u -l 90&#8217;</strong></span></p>
<p><span style="font-weight: 400;">or </span></p>
<p><span style="color: #0000ff;"><strong>$ ncat -u -l 80 -c &#8216; nc -u -l 90&#8217;</strong></span></p>
<p><span style="font-weight: 400;">here, all incoming connections from port 80 are being forwarded to port 90.</span></p>
<p>&nbsp;</p>
<h3><b>Using NC as a Proxy server</b></h3>
<p><span style="font-weight: 400;">Nc command can also act as a proxy server. To use the NC command as a proxy, use</span></p>
<p><span style="color: #0000ff;"><strong>$ nc &#8211; l 80 | nc 172.16.16.200 80</strong></span></p>
<p><span style="font-weight: 400;">or </span></p>
<p><span style="color: #0000ff;"><strong>$ ncat &#8211; l 80 | nc 172.16.16.200 80</strong></span></p>
<p><span style="font-weight: 400;">here, all incoming connections to port 8080 on localhost are being redirected to the 172.16.16.200 server on port 80, as we do with the help of a proxy server.  But this proxy is currently only one way, i.e. it will send the connections to the remote server but can not receive any packets in response.</span></p>
<p><span style="font-weight: 400;"> To create a return passage or 2-way communication channel, use the following commands,</span></p>
<p><span style="color: #0000ff;"><strong>$ mkfifo 2way</strong></span></p>
<p><span style="color: #0000ff;"><strong>$ nc &#8211; l 80 0&lt;2way | nc 172.16.16.200 80 1&gt;2way</strong></span></p>
<p><span style="font-weight: 400;">We now have a fully working 2-way proxy server using the ncat command.</span></p>
<p>&nbsp;</p>
<h3><b>Using NC as a chat tool</b></h3>
<p><span style="font-weight: 400;">Another way to make use of the NC command is using it as a chat tool. Weird but it’s possible. To create a chat tool using the nc command, first, start it in listening mode,</span></p>
<p><span style="color: #0000ff;"><strong>$ nc &#8211; l 8080</strong></span></p>
<p><span style="font-weight: 400;">or </span></p>
<p><span style="color: #0000ff;"><strong>$ ncat &#8211; l 8080</strong></span></p>
<p><span style="font-weight: 400;">Then from the remote machine, connect to the first server that is listening to port 8080,</span></p>
<p><span style="color: #0000ff;"><strong>$ nc 172.16.16.100 8080</strong></span></p>
<p><span style="font-weight: 400;">or </span></p>
<p><span style="color: #0000ff;"><strong>$ ncat 172.16.16.100 8080</strong></span></p>
<p><span style="font-weight: 400;">That’s it, you have a working chat tool on your hand. Now we can start a conversation using the terminal/CLI.</span></p>
<p><img loading="lazy" class="alignnone size-full wp-image-1355 jetpack-lazy-image" src="https://i1.wp.com/thelinuxgurus.com/wp-content/uploads/2021/03/nc-command-e1616600969775.png?resize=720%2C160&#038;ssl=1" alt="nc command in linux" width="720" height="160" data-recalc-dims="1" data-lazy-src="https://i1.wp.com/thelinuxgurus.com/wp-content/uploads/2021/03/nc-command-e1616600969775.png?resize=720%2C160&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img loading="lazy" class="alignnone size-full wp-image-1355" src="https://i1.wp.com/thelinuxgurus.com/wp-content/uploads/2021/03/nc-command-e1616600969775.png?resize=720%2C160&#038;ssl=1" alt="nc command in linux" width="720" height="160" data-recalc-dims="1" /></noscript></p>
<p>&nbsp;</p>
<h3><b>Using Ncat to create a system backdoor</b></h3>
<p><span style="font-weight: 400;"><strong>Note:</strong> This will only work with the ncat command.</span></p>
<p><span style="font-weight: 400;">One of the most common ways that the ncat command in Linux is used for bad is by using it to create a backdoor. Nc command is used to create a backdoor to our system which can be exploited by hackers (I am mentioning this just for information &amp; so that you can safeguard against these kinds of attacks. You guys should not be using it for wrong purposes, it’s completely wrong, unethical &amp; not to mention can be illegal as well).</span></p>
<p><span style="font-weight: 400;">To create a backdoor,</span></p>
<p><span style="color: #0000ff;"><strong>$ ncat -l 5500 -e /bin/bash</strong></span></p>
<p><span style="font-weight: 400;">here, we have attached port 5500 to /bin/bash, which can now be connected from a remote machine to execute the commands,</span></p>
<p><span style="color: #0000ff;"><strong>$ ncat 172.16.16.100 5500</strong></span></p>
<p><span style="font-weight: 400;">As seen in the screenshot above, I created a backdoor on one tab &amp; then on the second tab I connected to that backdoor &amp; was able to run some commands like ‘date’, ‘df -h’ etc. You can run other commands as well &amp; consider if this backdoor is created as the root user, hackers will have complete access to your system. </span></p>
<p><img loading="lazy" class="alignnone wp-image-1356 size-full jetpack-lazy-image" src="https://i2.wp.com/thelinuxgurus.com/wp-content/uploads/2021/03/nc-command-2-e1616601010342.png?resize=720%2C229&#038;ssl=1" alt="ncat command in linux" width="720" height="229" data-recalc-dims="1" data-lazy-src="https://i2.wp.com/thelinuxgurus.com/wp-content/uploads/2021/03/nc-command-2-e1616601010342.png?resize=720%2C229&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img loading="lazy" class="alignnone wp-image-1356 size-full" src="https://i2.wp.com/thelinuxgurus.com/wp-content/uploads/2021/03/nc-command-2-e1616601010342.png?resize=720%2C229&#038;ssl=1" alt="ncat command in linux" width="720" height="229" data-recalc-dims="1" /></noscript></p>
<h3><b>Force server to remain up</b></h3>
<p><span style="font-weight: 400;">The server will stop listening for connection once a client connection has been terminated. But with option ‘k’, we can force a server to remain running, even when no client is connected.</span></p>
<p><span style="color: #0000ff;"><strong>$ nc -l -k 8080</strong></span></p>
<p><span style="font-weight: 400;">These were only some examples of how to use the nc command or ncat command in Linux. There are certainly more ways to use this, GOOD as well as BAD. So use wisely.</span></p>
<p><span style="font-weight: 400;">If you have any questions or queries regarding the tutorial, please do let us know using the comment box below.</span></p>
<div style="padding: 1.5em; background: #E1DDDD; border: 0.125em solid #c5dbe5; border-width: 0.125em 0;">
<p style="margin-bottom: 0.75em;">If you think we have helped you or just want to support us, please consider these:-</p>
<p style="margin-bottom: 0.75em;">Connect to us: <a href="https://www.facebook.com/thelinuxgurus/"><span style="color: #ff0000;">Facebook</span></a> | <a href="https://twitter.com/thelinuxgurus"><span style="color: #ff0000;">Twitter</span></a> | <a href="https://www.linkedin.com/in/thelinuxgurus/"><span style="color: #ff0000;">Linkedin</span></a></p>
<p style="margin-bottom: 0.75em;">TheLinuxGURUS are thankful for your continued support.</p>
</div>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-1353" class="share-twitter sd-button share-icon no-text" href="https://thelinuxgurus.com/informative-guide-to-nc-ncat-command-in-linux/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon no-text" href="https://thelinuxgurus.com/informative-guide-to-nc-ncat-command-in-linux/?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon no-text" href="https://thelinuxgurus.com/informative-guide-to-nc-ncat-command-in-linux/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span></span><span class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-1353" class="share-pinterest sd-button share-icon no-text" href="https://thelinuxgurus.com/informative-guide-to-nc-ncat-command-in-linux/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-pocket"><a rel="nofollow noopener noreferrer" data-shared="" class="share-pocket sd-button share-icon no-text" href="https://thelinuxgurus.com/informative-guide-to-nc-ncat-command-in-linux/?share=pocket" target="_blank" title="Click to share on Pocket"><span></span><span class="sharing-screen-reader-text">Click to share on Pocket (Opens in new window)</span></a></li><li class="share-telegram"><a rel="nofollow noopener noreferrer" data-shared="" class="share-telegram sd-button share-icon no-text" href="https://thelinuxgurus.com/informative-guide-to-nc-ncat-command-in-linux/?share=telegram" target="_blank" title="Click to share on Telegram"><span></span><span class="sharing-screen-reader-text">Click to share on Telegram (Opens in new window)</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon no-text" href="https://thelinuxgurus.com/informative-guide-to-nc-ncat-command-in-linux/?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span></span><span class="sharing-screen-reader-text">Click to share on WhatsApp (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-1353" class="share-facebook sd-button share-icon no-text" href="https://thelinuxgurus.com/informative-guide-to-nc-ncat-command-in-linux/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon no-text" href="https://thelinuxgurus.com/informative-guide-to-nc-ncat-command-in-linux/?share=email" target="_blank" title="Click to email this to a friend"><span></span><span class="sharing-screen-reader-text">Click to email this to a friend (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-1353" class="share-linkedin sd-button share-icon no-text" href="https://thelinuxgurus.com/informative-guide-to-nc-ncat-command-in-linux/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-skype"><a rel="nofollow noopener noreferrer" data-shared="sharing-skype-1353" class="share-skype sd-button share-icon no-text" href="https://thelinuxgurus.com/informative-guide-to-nc-ncat-command-in-linux/?share=skype" target="_blank" title="Click to share on Skype"><span></span><span class="sharing-screen-reader-text">Click to share on Skype (Opens in new window)</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button share-icon no-text" href="https://thelinuxgurus.com/informative-guide-to-nc-ncat-command-in-linux/#print" target="_blank" title="Click to print"><span></span><span class="sharing-screen-reader-text">Click to print (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div>                                                            </div>
                            <div class="clear"></div>

                            
                            
                                                            <!-- start: .share-buttons -->
                                <div class="share-buttons section">
                                    <h5 class="title small">Share Article:</h5>
                                                                        <div class="epcl-share-bottom">
            
        <a class="facebook epcl-button circle" rel="nofollow" href="https://www.facebook.com/sharer/sharer.php?u=https://wp.me/pa4Rkr-lP"
onclick="window.open(this.href, 'facebook-share','width=580,height=296');return false;"><i class="fa fa-facebook"></i></a>
            
    <a class="twitter epcl-button circle" rel="nofollow" href="http://twitter.com/share?text=Informative+guide+to+NC+%28Ncat%29+command+in+Linux&url=https://wp.me/pa4Rkr-lP"
onclick="window.open(this.href, 'twitter-share', 'width=550,height=235');return false;"><i class="fa fa-twitter"></i></a>
            
        <a class="linkedin epcl-button circle" rel="nofollow" href="https://www.linkedin.com/shareArticle?mini=true&url=https://wp.me/pa4Rkr-lP&title=Informative+guide+to+NC+%28Ncat%29+command+in+Linux&summary=Ncat+command+in+Linux+or+NC+command+is+used+in+the+maintenance+or+diagnosis-related+tasks+for+a+network.+Even+though+the+%E2%80%98nc+command%E2%80%99+or+%E2%80%98ncat..." onclick="window.open(this.href, 'linkedin-share', 'width=490,height=530');return false;"><i class="fa fa-linkedin"></i></a>
            
        <a class="pinterest epcl-button circle" rel="nofollow" href="//pinterest.com/pin/create/link/?url=https://wp.me/pa4Rkr-lP&media=https://thelinuxgurus.com/wp-content/uploads/2021/03/unnamed-file.png&description=Informative+guide+to+NC+%28Ncat%29+command+in+Linux" onclick="window.open(this.href, 'pinterest-share', 'width=490,height=530');return false;"><i class="fa fa-pinterest"></i></a>
            
        <a class="telegram epcl-button circle" rel="nofollow" href="https://telegram.me/share/url?url=https://wp.me/pa4Rkr-lP&text=Informative+guide+to+NC+%28Ncat%29+command+in+Linux" onclick="window.open(this.href, 'telegram-share', 'width=490,height=530');return false;"><i class="fa fa-telegram"></i></a>
                
        <a class="email epcl-button circle" rel="nofollow" href="mailto:?subject=Informative+guide+to+NC+%28Ncat%29+command+in+Linux&body=https://wp.me/pa4Rkr-lP" target="_blank"><i class="fa fa-envelope"></i></a>
            
            <a class="whatsapp epcl-button circle" rel="nofollow" href="https://api.whatsapp.com/send?text=https://wp.me/pa4Rkr-lP" data-action="share/whatsapp/share"><i class="fa fa-whatsapp"></i></a>    
        </div>                                    <div class="clear"></div>
                                    <div class="permalink">
                                        <input type="text" name="shortlink" value="https://thelinuxgurus.com/informative-guide-to-nc-ncat-command-in-linux/" id="copy-link" readonly>
                                        <span class="copy"><svg><use xlink:href="#copy"></use></svg></span>
                                    </div>
                                </div>
                                <!-- end: .share-buttons -->
                            
                        </section>

                                                    <div class="bottom-tags">
                                <i class="remixicon remixicon-price-tag-3-line"></i>
                                <a href="https://thelinuxgurus.com/tag/commands/" rel="tag">commands</a>, <a href="https://thelinuxgurus.com/tag/linux-commands/" rel="tag">linux commands</a>, <a href="https://thelinuxgurus.com/tag/nc/" rel="tag">nc</a>, <a href="https://thelinuxgurus.com/tag/ncat/" rel="tag">ncat</a>                            </div>
                        
                        
                    </article>
                    <div class="clear"></div>

                    	    
    <!-- start: .author -->
    <section id="author" class="author  with-avatar section">
                    <div class="avatar">
                    <a href="https://thelinuxgurus.com/author/shsuain/" class="hover-effect thumb"><span class="fullimage cover" style="background-image: url('https://secure.gravatar.com/avatar/37eb7ad923802078085e9d33fcc08567?s=192&#038;d=mm&#038;r=g');"></span></a>
            </div>
                <div class="info">
                            <h4 class="title author-name gradient-effect"><a href="https://thelinuxgurus.com/author/shsuain/">Prince DAN</a></h4>
            	
            
            <p></p>
            <div class="social">
                                                                                            </div>
        </div>
        <div class="clear"></div>
    </section>
    <!-- end: .author -->
    <div class="clear"></div>

                    
                        <section class="related section">
                                                                                        <article class="prev grid-50 tablet-grid-50 grid-parent">
                                                                                                                        <div class="thumb cover lazy" data-src="https://i2.wp.com/thelinuxgurus.com/wp-content/uploads/2021/03/msedge_kNpbVB9vPT.png?fit=700%2C409&#038;ssl=1"></div>
                                                                                                                <a href="https://thelinuxgurus.com/how-to-use-find-command-in-linux/" class="full-link"></a>                              
                                    <div class="info">
                                                                                    <time datetime="2021-03-16">
                                                March 16, 2021                                            </time>
                                                                                <h4 class="title white no-margin">How to use FIND command in Linux</h4>
                                    </div>                                
                                    <span class="epcl-button red"><img src="https://thelinuxgurus.com/wp-content/themes/breek/assets/images/left-arrow.svg" width="15" alt="Left Arrow"></span>
                                    <div class="overlay"></div>
                                </article>
                            
                                                                                    <div class="clear"></div>
                        </section>

                    
                    <div class="clear"></div>

                                            
    <!-- start: #comments -->
    <div id="comments" class="bg-white hosted ">

                	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title title bordered">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/informative-guide-to-nc-ncat-command-in-linux/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://thelinuxgurus.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><textarea id="comment" name="comment" aria-required="true" rows="10" placeholder="Comment"></textarea><input class="form-author" name="author" type="text" placeholder="Name" value="" size="30" aria-required='true' required />
<input class="form-email" name="email" type="text" placeholder="Email" value="" size="30" aria-required='true' required />
<input class="form-website" name="url" type="text" placeholder="Website" value="" size="30" />
<p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="epcl-button" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='1353' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="7118222128" /></p><input type="hidden" id="ak_js" name="ak_js" value="109"/><textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100" style="display: none !important;"></textarea></form>	</div><!-- #respond -->
	<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p>        <div class="clear"></div>
    </div>
    <!-- end: #comments -->
                    
                    
                    
                    <div class="clear"></div>
                </div>
                <!-- end: .content -->

                    <!-- start: #sidebar -->
    <aside id="sidebar" class="grid-30 np-mobile no-sidebar">
        <div class="default-sidebar"><section id="search-2" class="widget widget_search"><form action="https://thelinuxgurus.com/" method="get" class="search-form">
	<input type="text" name="s" id="s" value="" class="search-field" placeholder="Type to start your search..." aria-label="Type to start your search..." required>
	<button type="submit" class="submit" aria-label="Submit"><i class="remixicon remixicon-search-line"></i></button>
</form>
<div class="clear"></div></section><section id="media_image-3" class="widget widget_media_image"><a href="https://thelinuxgurus.com"><img width="600" height="600" src="https://i1.wp.com/thelinuxgurus.com/wp-content/uploads/2020/01/thelinuxgurus.jpg?fit=600%2C600&amp;ssl=1" class="image wp-image-991  attachment-full size-full jetpack-lazy-image" alt="" loading="lazy" style="max-width: 100%; height: auto;" data-lazy-srcset="https://i1.wp.com/thelinuxgurus.com/wp-content/uploads/2020/01/thelinuxgurus.jpg?w=600&amp;ssl=1 600w, https://i1.wp.com/thelinuxgurus.com/wp-content/uploads/2020/01/thelinuxgurus.jpg?resize=300%2C300&amp;ssl=1 300w, https://i1.wp.com/thelinuxgurus.com/wp-content/uploads/2020/01/thelinuxgurus.jpg?resize=80%2C80&amp;ssl=1 80w" data-lazy-sizes="(max-width: 600px) 100vw, 600px" data-lazy-src="https://i1.wp.com/thelinuxgurus.com/wp-content/uploads/2020/01/thelinuxgurus.jpg?fit=600%2C600&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a><div class="clear"></div></section><section id="epcl_social-4" class="widget widget_epcl_social"><h4 class="widget-title title bordered">Social</h4><div class="icons title"><a href="https://twitter.com/thelinuxgurus" class="twitter" target="_blank" rel="nofollow noopener"><i class="fa fa-twitter"></i><p>Twitter <span>Follow me!</span></p></a><a href="https://www.facebook.com/thelinuxgurus" class="facebook" target="_blank" rel="nofollow noopener"><i class="fa fa-facebook"></i><p>Facebook <span>Follow me!</span></p></a><a href="https://www.instagram.com/thelinuxgurus/" class="instagram" target="_blank" rel="nofollow noopener"><i class="fa fa-instagram"></i><p>Instagram <span>Our photos!</span></p></a><a href="https://in.linkedin.com/in/linuxtechlab" class="linkedin" target="_blank" rel="nofollow noopener"><i class="fa fa-linkedin"></i> <p>Linkedin <span>Visit me!</span></p></a><a href="https://id.pinterest.com/thelinuxgurus/" class="pinterest" target="_blank" rel="nofollow noopener"><i class="fa fa-pinterest"></i><p>Pinterest <span>Pin it!</span></p></a><a href="https://thelinuxgurus.tumblr.com/" class="tumblr" target="_blank" rel="nofollow noopener"><i class="fa fa-tumblr"></i><p>Tumblr <span>Visit me!</span></p></a></div><div class="clear"></div></section>
		<section id="recent-posts-2" class="widget widget_recent_entries">
		<h4 class="widget-title title bordered">Recent Posts</h4>
		<ul>
											<li>
					<a href="https://thelinuxgurus.com/informative-guide-to-nc-ncat-command-in-linux/" aria-current="page">Informative guide to NC (Ncat) command in Linux</a>
									</li>
											<li>
					<a href="https://thelinuxgurus.com/how-to-use-find-command-in-linux/">How to use FIND command in Linux</a>
									</li>
											<li>
					<a href="https://thelinuxgurus.com/how-to-use-nmap-command-to-test-server-network-security/">How to use NMAP command to test Server/Network Security</a>
									</li>
											<li>
					<a href="https://thelinuxgurus.com/how-to-execute-a-command-or-a-script-on-system-startup-or-reboot/">How to Execute a Command or a Script on system Startup or Reboot</a>
									</li>
											<li>
					<a href="https://thelinuxgurus.com/simple-guide-to-secure-redis-installation/">Simple guide to secure Redis Installation</a>
									</li>
					</ul>

		<div class="clear"></div></section></div>
                    <div class="mobile-sidebar hide-on-desktop"><section id="epcl_social-3" class="widget widget_epcl_social"><h4 class="widget-title title bordered">Social</h4><div class="icons title"><a href="https://twitter.com/thelinuxgurus" class="twitter" target="_blank" rel="nofollow noopener"><i class="fa fa-twitter"></i><p>Twitter <span>Follow me!</span></p></a><a href="https://www.facebook.com/thelinuxgurus" class="facebook" target="_blank" rel="nofollow noopener"><i class="fa fa-facebook"></i><p>Facebook <span>Follow me!</span></p></a><a href="https://www.instagram.com/thelinuxgurus/" class="instagram" target="_blank" rel="nofollow noopener"><i class="fa fa-instagram"></i><p>Instagram <span>Our photos!</span></p></a><a href="https://in.linkedin.com/in/linuxtechlab" class="linkedin" target="_blank" rel="nofollow noopener"><i class="fa fa-linkedin"></i> <p>Linkedin <span>Visit me!</span></p></a><a href="https://id.pinterest.com/thelinuxgurus/" class="pinterest" target="_blank" rel="nofollow noopener"><i class="fa fa-pinterest"></i><p>Pinterest <span>Pin it!</span></p></a><a href="https://thelinuxgurus.tumblr.com/" class="tumblr" target="_blank" rel="nofollow noopener"><i class="fa fa-tumblr"></i><p>Tumblr <span>Visit me!</span></p></a></div><div class="clear"></div></section></div>
            </aside>
    <!-- end: #sidebar -->

            </div>
            <!-- end: .epcl-page-wrapper -->            
        
        </div>
        <!-- end: .center -->

	</main>
	<!-- end: #single -->




        <!-- start: #footer -->
<footer id="footer" class="grid-container ">

            <div class="widgets row gradient-effect">
            <div class="default-sidebar border-effect"><div class="grid-33 tablet-grid-50 mobile-grid-100"><section id="nav_menu-2" class="widget widget_nav_menu underline-effect"><div class="menu-footer-nav-container"><ul id="menu-footer-nav" class="menu"><li id="menu-item-669" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-669"><a href="https://thelinuxgurus.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-727" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-727"><a href="https://thelinuxgurus.com/cookie-policy/">Cookie Policy</a></li>
<li id="menu-item-1349" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1349"><a href="https://thelinuxgurus.com/terms-conditions/">Terms &#038; Conditions</a></li>
<li id="menu-item-728" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-728"><a href="https://thelinuxgurus.com/get-in-touch/">Contact Us</a></li>
</ul></div><div class="clear"></div></section></div></div>
            <div class="clear"></div>
                        <div class="clear"></div>
        </div>
    
                                <h2 class="logo">
                <a href="https://thelinuxgurus.com/" class="title white medium">
                                        The Linux GURUS                </a>
            </h2>
            
	            <a id="back-to-top" class="epcl-button dark"><i class="remixicon remixicon-arrow-up-line"></i></a>
    
</footer>
<!-- end: #footer -->
        <div class="clear"></div>
    </div>
    <!-- end: #wrapper --> 

    <!-- W3TC-include-css -->
    <!-- W3TC-include-js-head -->

    <!--googleoff: all--><div id="cookie-law-info-bar" data-nosnippet="true"><span>This website uses cookies to improve your experience. We'll assume you're ok with this, but you can opt-out if you wish.<a role='button' tabindex='0' data-cli_action="accept" id="cookie_action_close_header"  class="medium cli-plugin-button cli-plugin-main-button cookie_action_close_header cli_action_button" style="display:inline-block; ">Accept</a> <a href='https://thelinuxgurus.com' id="CONSTANT_OPEN_URL" target="_blank"  class="cli-plugin-main-link"  style="display:inline-block;" >Read More</a></span></div><div id="cookie-law-info-again" style="display:none;" data-nosnippet="true"><span id="cookie_hdr_showagain">Privacy & Cookies Policy</span></div><div class="cli-modal" data-nosnippet="true" id="cliSettingsPopup" tabindex="-1" role="dialog" aria-labelledby="cliSettingsPopup" aria-hidden="true">
  <div class="cli-modal-dialog" role="document">
	<div class="cli-modal-content cli-bar-popup">
	  	<button type="button" class="cli-modal-close" id="cliModalClose">
			<svg class="" viewBox="0 0 24 24"><path d="M19 6.41l-1.41-1.41-5.59 5.59-5.59-5.59-1.41 1.41 5.59 5.59-5.59 5.59 1.41 1.41 5.59-5.59 5.59 5.59 1.41-1.41-5.59-5.59z"></path><path d="M0 0h24v24h-24z" fill="none"></path></svg>
			<span class="wt-cli-sr-only">Close</span>
	  	</button>
	  	<div class="cli-modal-body">
			<div class="cli-container-fluid cli-tab-container">
	<div class="cli-row">
		<div class="cli-col-12 cli-align-items-stretch cli-px-0">
			<div class="cli-privacy-overview">
				<h4>Privacy Overview</h4>				<div class="cli-privacy-content">
					<div class="cli-privacy-content-text">This website uses cookies to improve your experience while you navigate through the website. Out of these cookies, the cookies that are categorized as necessary are stored on your browser as they are essential for the working of basic functionalities of the website. We also use third-party cookies that help us analyze and understand how you use this website. These cookies will be stored in your browser only with your consent. You also have the option to opt-out of these cookies. But opting out of some of these cookies may have an effect on your browsing experience.</div>
				</div>
				<a class="cli-privacy-readmore"  aria-label="Show more" tabindex="0" role="button" data-readmore-text="Show more" data-readless-text="Show less"></a>			</div>
		</div>
		<div class="cli-col-12 cli-align-items-stretch cli-px-0 cli-tab-section-container">
												<div class="cli-tab-section">
						<div class="cli-tab-header">
							<a role="button" tabindex="0" class="cli-nav-link cli-settings-mobile" data-target="necessary" data-toggle="cli-toggle-tab">
								Necessary							</a>
							<div class="wt-cli-necessary-checkbox">
                        <input type="checkbox" class="cli-user-preference-checkbox"  id="wt-cli-checkbox-necessary" data-id="checkbox-necessary" checked="checked"  />
                        <label class="form-check-label" for="wt-cli-checkbox-necessary">Necessary</label>
                    </div>
                    <span class="cli-necessary-caption">Always Enabled</span> 						</div>
						<div class="cli-tab-content">
							<div class="cli-tab-pane cli-fade" data-id="necessary">
								<p>Necessary cookies are absolutely essential for the website to function properly. This category only includes cookies that ensures basic functionalities and security features of the website. These cookies do not store any personal information.</p>
							</div>
						</div>
					</div>
																	<div class="cli-tab-section">
						<div class="cli-tab-header">
							<a role="button" tabindex="0" class="cli-nav-link cli-settings-mobile" data-target="non-necessary" data-toggle="cli-toggle-tab">
								Non-necessary							</a>
							<div class="cli-switch">
                        <input type="checkbox" id="wt-cli-checkbox-non-necessary" class="cli-user-preference-checkbox"  data-id="checkbox-non-necessary"  checked='checked' />
                        <label for="wt-cli-checkbox-non-necessary" class="cli-slider" data-cli-enable="Enabled" data-cli-disable="Disabled"><span class="wt-cli-sr-only">Non-necessary</span></label>
                    </div>						</div>
						<div class="cli-tab-content">
							<div class="cli-tab-pane cli-fade" data-id="non-necessary">
								<p>Any cookies that may not be particularly necessary for the website to function and is used specifically to collect user personal data via analytics, ads, other embedded contents are termed as non-necessary cookies. It is mandatory to procure user consent prior to running these cookies on your website.</p>
							</div>
						</div>
					</div>
										</div>
	</div>
</div>
	  	</div>
	  	<div class="cli-modal-footer">
			<div class="wt-cli-element cli-container-fluid cli-tab-container">
				<div class="cli-row">
					<div class="cli-col-12 cli-align-items-stretch cli-px-0">
						<div class="cli-tab-footer wt-cli-privacy-overview-actions">
						
															<a id="wt-cli-privacy-save-btn" role="button" tabindex="0" data-cli-action="accept" class="wt-cli-privacy-btn cli_setting_save_button wt-cli-privacy-accept-btn cli-btn">SAVE & ACCEPT</a>
													</div>
						
					</div>
				</div>
			</div>
		</div>
	</div>
  </div>
</div>
<div class="cli-modal-backdrop cli-fade cli-settings-overlay"></div>
<div class="cli-modal-backdrop cli-fade cli-popupbar-overlay"></div>
<!--googleon: all--><a href="https://newsangels.com/">NEWS ANGELS</a>
	
							<div id="sharing_email" style="display: none;">
		<form action="/informative-guide-to-nc-ncat-command-in-linux/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			
			<img style="float: right; display: none" class="loading" src="https://thelinuxgurus.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel" role="button">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<link rel='stylesheet' id='epcl-fontawesome-css'  href='https://thelinuxgurus.com/wp-content/themes/breek/assets/dist/fontawesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='epcl-remixicons-css'  href='https://thelinuxgurus.com/wp-content/themes/breek/assets/dist/remixicons.min.css' type='text/css' media='all' />

<script type='text/javascript' src='https://thelinuxgurus.com/wp-includes/js/dist/vendor/wp-polyfill.min.js' id='wp-polyfill-js'></script>
<script type='text/javascript' id='wp-polyfill-js-after'>
( 'fetch' in window ) || document.write( '<script src="https://thelinuxgurus.com/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://thelinuxgurus.com/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js"></scr' + 'ipt>' );( window.DOMRect ) || document.write( '<script src="https://thelinuxgurus.com/wp-includes/js/dist/vendor/wp-polyfill-dom-rect.min.js"></scr' + 'ipt>' );( window.URL && window.URL.prototype && window.URLSearchParams ) || document.write( '<script src="https://thelinuxgurus.com/wp-includes/js/dist/vendor/wp-polyfill-url.min.js"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://thelinuxgurus.com/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://thelinuxgurus.com/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js"></scr' + 'ipt>' );( 'objectFit' in document.documentElement.style ) || document.write( '<script src="https://thelinuxgurus.com/wp-includes/js/dist/vendor/wp-polyfill-object-fit.min.js"></scr' + 'ipt>' );
</script>
<script type='text/javascript' src='https://thelinuxgurus.com/wp-includes/js/dist/hooks.min.js' id='wp-hooks-js'></script>
<script type='text/javascript' src='https://thelinuxgurus.com/wp-includes/js/dist/i18n.min.js' id='wp-i18n-js'></script>

<script type='text/javascript' src='https://thelinuxgurus.com/wp-includes/js/dist/vendor/lodash.min.js' id='lodash-js'></script>

<script type='text/javascript' src='https://thelinuxgurus.com/wp-includes/js/dist/url.min.js' id='wp-url-js'></script>

<script type='text/javascript' src='https://thelinuxgurus.com/wp-includes/js/dist/api-fetch.min.js' id='wp-api-fetch-js'></script>
<script type='text/javascript' id='wp-api-fetch-js-after'>
wp.apiFetch.use( wp.apiFetch.createRootURLMiddleware( "https://thelinuxgurus.com/wp-json/" ) );
wp.apiFetch.nonceMiddleware = wp.apiFetch.createNonceMiddleware( "6b98cdc906" );
wp.apiFetch.use( wp.apiFetch.nonceMiddleware );
wp.apiFetch.use( wp.apiFetch.mediaUploadMiddleware );
wp.apiFetch.nonceEndpoint = "https://thelinuxgurus.com/wp-admin/admin-ajax.php?action=rest-nonce";
</script>


<script type='text/javascript' id='epcl-scripts-js-extra'>
/* <![CDATA[ */
var ajax_var = {"url":"https:\/\/thelinuxgurus.com\/wp-admin\/admin-ajax.php","nonce":"82c25b5a88","assets_folder":"https:\/\/thelinuxgurus.com\/wp-content\/themes\/breek\/assets"};
/* ]]> */
</script>






<script type='text/javascript' src='https://cdn.onesignal.com/sdks/OneSignalSDK.js?ver=06a449a9cb1fefb73534493ef2d908b0' async='async' id='remote_sdk-js'></script>




<script src='https://stats.wp.com/e-202112.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.5',blog:'148921671',post:'1353',tz:'5.5',srv:'thelinuxgurus.com'} ]);
	_stq.push([ 'clickTrackerInit', '148921671', '1353' ]);
</script>
            <script defer src="https://thelinuxgurus.com/wp-content/cache/autoptimize/js/autoptimize_46d42664bebf8e6b4ef6eb14c106afab.js"></script></body>
</html>

<!--
Performance optimized by W3 Total Cache. Learn more: https://www.boldgrid.com/w3-total-cache/

Object Caching 17/188 objects using disk
Page Caching using disk: enhanced 

Served from: thelinuxgurus.com @ 2021-03-26 04:36:21 by W3 Total Cache
-->